Compiling Aegisub on Ubuntu 9.10

So thats a mess, ok. I found out that the stable versions require more modern FFMPEG as Ubuntu 9.10 provides. The solution is to use an older package then.

you need to download a version not younger than aegisub-2.1.6-dev-r2740.tar.gz (Revision 2740) from February 18th 2009 from http://www.mahou.org/~verm/aegisub/archives/ and can confirm that this can include newest FFMPEG. For those who still dont know: There is no ffmpeg-dev, but you have to install different libraries -dev packages(most start with libav, I think essential should be: libavformat-dev and libavcode-dev) and also libhunspell-dev (HUNSPELL) for spell checking.

So my recommendation for Ubuntu to date is NOT to use the SVN version. I dont know why the require such new version of FFMPEG. It makes building unnecessary hard in my opinion.

I also installed these packages: ruby1.8-dev (otherwise you get “auto4_ruby.h:48:18: error: ruby.h: No such file or directory“), libperl-dev,…

Then you can enter directory and type

./configure
./make

And if that works ok:

sudo make install

That worked for me. If I missed soemthing ot you have questions pleas comment. And sorry I am not up to package building, yet. If a newer version works I will update this page, also.

Advertisements

Leave a comment

Filed under Free Software, Technology

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s